Monday, 30 July 2012

cisco router configuration, cisco iso router configuration commands

Cisco IOS Router Commands


There are 3 modes operation the Cisco IOS.
·        Disabled mode
·        Enabled mode
·        Configuration mode

Disabled mode you can use a limited number of commands. This is used primarily to monitor the router.
Enabled mode is used to show configuration information, enter the configuration mode, and make changes to the configuration.
Configuration mode is used to enter and update the runtime configuration.
To get a list of the commands for the cisco type '?' at the prompt. Further information about any command, type the command followed by  '?'.
clear
Reset functions
clock
Manage the system clock
configure
Enter configuration mode
debug
Debugging functions (see also 'undebug')
disable
Turn off privileged commands
enable
Turn on privileged commands
erase
Erase flash or configuration memory
exit
Exit from the EXEC
help
Description of the interactive help system
login
Log in as a particular user
logout
Exit from the EXEC
no
Disable debugging functions
ping
Send echo messages
reload
Halt and perform a cold restart
setup
Run the SETUP command facility
show
Show running system information
telnet
Open a telnet connection
terminal
Set terminal line parameters
test
Test subsystems, memory, and interfaces
traceroute
Trace route to destination
tunnel
Open a tunnel connection
undebug
Disable debugging functions (see also 'debug')
verify
Verify checksum of a Flash file
write
Write running configuration to memory, network, or terminal

show

access-lists
List access lists
arp
ARP table
buffers
Buffer pool statistics
configuration
Contents of Non-Volatile memory
controllers
Interface controller status
debugging
State of each debugging option
dialer
Dialer parameters and statistics
extended
Extended Interface Information
flash
System Flash information
flh-log
Flash Load Helper log buffer
history
Display the session command history
hosts
IP domain-name, lookup style, name servers, and host table
interfaces
Interface status and configuration
ip
IP information
isdn
ISDN information
line
TTY line information
logging
Show the contents of logging buffers
memory
Memory statistics
privilege
Show current privilege level
processes
Active process statistics
protocols
Active network routing protocols
queue
Show queue contents
queueing
Show queueing configuration
reload
Scheduled reload information
route-map
route-map information
running-config
Current operating configuration
sessions
Information about Telnet connections
smf
Software MAC filter
stacks
Process stack utilization
startup-config
Contents of startup configuration
subsys
Show subsystem information
tcp
Status of TCP connections
terminal
Display terminal configuration parameters
users
Display information about terminal lines
version
System hardware and software status

Other Useful Commands

View the Software Version
View the Ethernet IP
View the Serial IP
View the Default Route
View the Filters
View the Bandwidth
Add a Static Route
Change the Dial Number
Turn Filters On and Off
Ping from the Router
Traceroute from the Router

View the Software Version

Cisco>en
Cisco#wr term    <--- Shows running configuration    
Building configuration...
Current configuration:
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname Cisco
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial0
 ip address 192.168.6.1 255.255.255.0
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial1
 ip address 192.168.4.2 255.255.255.0
 encapsulation frame-relay
 bandwidth 1536
 keepalive 5
 frame-relay map ip 192.168.4.1 101 IETF
!
router rip
 version 2
 network 192.168.4.0
 network 192.168.6.0
 neighbor 192.168.6.2
 neighbor 192.168.4.1
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.6.2
ip route 0.0.0.0 0.0.0.0 192.168.4.1
!
line con 0
line aux 0
line vty 0 4
login
!
end

View Ethernet IP

Router#wr term





This will show the running configuration.
Within the configuration, see an interface ethernet 0 section:




interface Ethernet0
ip address 38.150.93.1 255.255.255.0
no ip directed-broadcast

View Serial IP

Router#wr term




Within the configuration, see an interface serial 0 section:




interface Serial0
ip address 38.21.10.100 255.255.255.0
ip broadcast-address 38.21.10.255
ip access-group 106 in
encapsulation frame-relay
bandwidth 56
no fair-queue
frame-relay map ip 38.21.10.1 500 IETF

View Default Route

Router#wr term




Within the configuration, see an ip route section. 




In the ip route section, look for a route:
ip route 0.0.0.0 0.0.0.0 38.167.29.1
The last ip address is the POP ip.

View Filters

Router#wr term




Under interface serial 0, look for:




ip access-group 104 in
ip access-group 105 out




Its means that access-group 104 is the inbound filter set and
access-group 105 is the outbound filter set.
Then, continue to look in the configuration for the access-list statements:




(Example for access-list statements)
access-list 104 deny   ip 38.166.101.0 0.0.0.255 any
access-list 104 permit tcp any any established
access-list 104 permit tcp any eq ftp-data any gt 1023
access-list 104 permit udp any eq domain any gt 1023
access-list 104 permit udp any eq domain any eq domain
access-list 104 permit icmp any any
access-list 104 permit udp any eq snmp any gt 1023
access-list 105 deny   ip any 38.166.101.0 0.0.0.255
access-list 105 permit tcp any any established
access-list 105 permit tcp any any eq ftp
access-list 105 deny   udp any eq netbios-ns any
access-list 105 deny   udp any eq netbios-dgm any
access-list 105 permit ip any any

View Bandwidth

Router#wr term




Within the config, see an interface serial 0 section:




interface Serial0
ip address 38.21.10.100 255.255.255.0
ip broadcast-address 38.21.10.255
ip access-group 106 in
encapsulation frame-relay
bandwidth 56
no fair-queue
frame-relay map ip 38.21.10.1 500 IETF

Add a Static Route

Cisco#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Cisco(config)#ip route DEST.DEST.DEST.DEST MASK.MASK.MASK.MASK GATE.GATE.GATE.GATE
where: DEST.DEST.DEST.DEST = The destination network the static route is for
       MASK.MASK.MASK.MASK = The subnet mask of the destination network
       GATE.GATE.GATE.GATE = The gateway of the static route
Example route statement:
ip route 38.222.75.0 255.255.255.0 38.20.5.1
Cisco(config)#^Z (hit <control> z)




Write the entry to memory:




Cisco#wr mem
Building configuration...
[OK]

Change Dial Number

Type en to put the router in enable mode:




test.com>en




The password should be the same as the one used to telnet in.




Password:




To view the router's configuration, type:




test.com#show config




There will be a line in the configuration that says:




dialer map IP 38.1.1.1 speed 64 name LD3330 2707000




The 2707000 is the dial number.




NOTE: Record what interface the dialer map IP line is under because you will need to
use that interface when changing the number.
 


Type config t to configure from terminal.




test.com#config t




Enter configuration commands, one per line.  End with CNTL/Z.
Enter the interface that the dialer map IP line is under:




test.com(config)#interface BRI0




Add in the new dialer map IP line with the new phone number:




test.com(config)#dialer map IP 38.1.1.1 speed 64 name LD3330 [new number]




Now, remove the old dialer map IP line.
To remove a line, type no and then the line.
For example, to remove the old dialer map IP, type:




test.com(config)#no dialer map IP 38.1.1.1 speed 64 name LD3330 2707020




Now leave config mode:




test.com(config)# [control] z




Save changes:




test.com# write mem
Building configuration...
[OK]




Verify the new number is in the config:




test.com#show config




The new number should be in the dialer map IP line.

Turn Filters On and Off

To turn the filters off:




Router#configure terminal
Router(config)#interface Serial0
Router(config-if)#no ip access-group 104 in
Router(config-if)#no ip access-group 105 out
Router(config-if)# Hit CTRL-Z
Router#wr mem
Building configuration...
[OK]
Router#




To turn the filters on:




Router#configure terminal
Router(config)#interface Serial0
Router(config-if)#ip access-group 104 in
Router(config-if)#ip access-group 105 out
Router(config-if)# Hit CTRL-Z
Router#wr mem
Building configuration...
[OK]
Router#

cisco router configuration, cisco router configuration commands

Cisco Router Configuration Commands

Learn Cisco Router Configuration code, its help to config router and clear all concepts in study.




RequirementCisco Command
Set a console password to ciscoRouter(config)#line con 0
Router(config-line)#login
Router(config-line)#password cisco
Set a telnet passwordRouter(config)#line vty 0 4
Router(config-line)#login
Router(config-line)#password cisco
Stop console timing outRouter(config)#line con 0
Router(config-line)#exec-timeout 0 0
Set the enable password to ciscoRouter(config)#enable password cisco
Set the enable secret password to peter.This password overrides the enable password
and is encypted within the config file
Router(config)#enable secret peter
Enable an interfaceRouter(config-if)#no shutdown
To disable an interfaceRouter(config-if)#shutdown
Set the clock rate for a router with a DCE cable to 64KRouter(config-if)clock rate 64000
Set a logical bandwidth assignment of 64K to the serial interfaceRouter(config-if)bandwidth 64
Note that the zeroes are not missing
To add an IP address to a interfaceRouter(config-if)#ip addr 10.1.1.1 255.255.255.0
To enable RIP on all 172.16.x.y interfacesRouter(config)#router rip
Router(config-router)#network 172.16.0.0
Disable RIPRouter(config)#no router rip
To enable IRGP with a AS of 200, to all interfacesRouter(config)#router igrp 200
Router(config-router)#network 172.16.0.0
Disable IGRPRouter(config)#no router igrp 200
Static route the remote network is 172.16.1.0, with a mask of 255.255.255.0, the next hop is 172.16.2.1, at a cost of 5 hopsRouter(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1 5
Disable CDP for the whole routerRouter(config)#no cdp run
Enable CDP for he whole routerRouter(config)#cdp run
Disable CDP on an interfaceRouter(config-if)#no cdp enable


Cisco Router Show Commands

RequirementCisco Command
View version informationshow version
View current configuration (DRAM)show running-config
View startup configuration (NVRAM)show startup-config
Show IOS file and flash spaceshow flash
Shows all logs that the router has in its memoryshow log
View the interface status of interface e0show interface e0
Overview all interfaces on the routershow ip interfaces brief
View type of serial cable on s0show controllers 0 (note the space between the 's' and the '0')
Display a summary of connected cdp devicesshow cdp neighbor
Display detailed information on all devicesshow cdp entry *
Display current routing protocolsshow ip protocols
Display IP routing tableshow ip route
Display access lists, this includes the number of displayed matchesshow access-lists
Check the router can see the ISDN switchshow isdn status
Check a Frame Relay PVC connectionsshow frame-relay pvc
show lmi traffic statsshow frame-relay lmi
Display the frame inverse ARP tableshow frame-relay map

Cisco Router Basic Operations

RequirementCisco Command
EnableEnter privileged mode
Return to user mode from privilegeddisable
Exit RouterLogout or exit or quit
Recall last commandup arrow or <Ctrl-P>
Recall next commanddown arrow or <Ctrl-N>
Suspend or abort<Shift> and  <Ctrl> and 6 then x
Refresh screen output<Ctrl-R>
Compleat CommandTAB

Cisco Router Copy Commands

RequirementCisco Command
Save the current configuration from DRAM to NVRAMcopy running-config startup-config
Merge NVRAM configuration to DRAMcopy startup-config running-config
Copy DRAM configuration to a TFTP servercopy runing-config tftp
Merge TFTP configuration with current router configuration held in DRAMcopy tftp runing-config
Backup the IOS onto a TFTP servercopy flash tftp
Upgrade the router IOS from a TFTP servercopy tftp flash

Cisco Router Debug Commands

RequirementCisco Command
Enable debug for RIPdebug ip rip
Enable summary IGRP debug informationdebug ip igrp events
Enable detailed IGRP debug informationdebug ip igrp transactions
Debug IPX RIPdebug ipx routing activity
Debug IPX SAPdebug IPX SAP
Enable debug for CHAP or PAPdebug ppp authentication
Switch all debugging offno debug all
undebug all

cisco router configuration tutorial, cisco router configuration pdf

Cisco Router Configuration Tutorial

Download CISCO Router Configuration Tutorial PDF File.

Sunday, 29 July 2012

cisco ipsubnet calculator, download ipsubnet calculator, subnetting calculator

Download ipsubnet calculator

  • This Calculator Helpful for who study in networking.
  • It is Helpful tools for CISCO Networking.
  • It is easily calculate any IP Network Address and All Host Address List.
  • Its help to Calculate Number of Subnet and Host.

For Download:  Click

Friday, 27 July 2012

cisco packet tracer download, cisco packet tracer

Download Cisco Packet Tracer Tutorial 



Cisco Packet Tracer Download Link: Click

CCNA exploration 4.0 curriculum and course installers, cisco certification exam curriculum , Cisco network curriculum part 1 to 4 download

Download CCNA Exploration 4.0 Curriculum and Course installers



CCNA Exploration Curriculum is 4 Part (CCNA-1, CCNA-2, CCNA-3 and CCNA-4)

 

Part 1 to 4Cisco Certification Exam Tutorial part 1 to 4 download


For CISCO Network Certification Exam, Need To complete CCNA Exploration Curriculum Part 1to 4. Its help you certified.

This Curriculum provide from Cisco network academy.

·        In Part 1 includes 11 chapters discuss about Network Fundamentals.
·        Part 2 also includes 11 chapters discuss about Routing Protocols and Concept.
·        Part 3 includes 7 chapters discuss about LAN Switching and Wireless.
·        Part 4 includes 8 chapters discuss about Access the WAN.


In Part 1 Chapter 6 and 11 is most important (Sub-netting and Configuration). Whole part 1 to 4 required this.


Download CCNA Exploration Curriculum 1 to 4